ubuntu 22 client vs web

gmarkham
Posts: 5
Joined: Thu Feb 04, 2021 7:03 pm

ubuntu 22 client vs web

Post by gmarkham » Wed Jun 12, 2024 9:07 pm

Hi,
I find that when I install the client for linux, it seems to run and function up to the point where I login. I use the same email and password with the client as I do the web, copying the credentials in fact during experiments trying to figure it out. I excluded any issue with proxy by starting with none, and then going with system (which is also set to none).
Web works, client doesn't, I am mystified. I have uninstalled, reinstalled, booting between changes, same result.
Is there a secret to running on Ubuntu I am missing?
I'll check back for clues, thank you for your consideration.
gmarkham@protonmail.com

embroider5169
Posts: 57
Joined: Wed Jul 19, 2023 5:46 pm

Re: ubuntu 22 client vs web

Post by embroider5169 » Thu Jun 13, 2024 7:40 am

How are you running Ubuntu? is it from within windows? is it a VM? Docker?
What version of Ubuntu are you running? Ubuntu LTS? Ubuntu Core, Ubuntu Server, Ubuntu Desktop, Ubuntu Pi?

kind regards,

BlompSupport
Posts: 828
Joined: Wed Feb 13, 2019 4:20 pm

Re: ubuntu 22 client vs web

Post by BlompSupport » Thu Jun 13, 2024 9:21 am

gmarkham wrote:
Wed Jun 12, 2024 9:07 pm
Hi,
I find that when I install the client for linux, it seems to run and function up to the point where I login. I use the same email and password with the client as I do the web, copying the credentials in fact during experiments trying to figure it out. I excluded any issue with proxy by starting with none, and then going with system (which is also set to none).
Web works, client doesn't, I am mystified. I have uninstalled, reinstalled, booting between changes, same result.
Is there a secret to running on Ubuntu I am missing?
I'll check back for clues, thank you for your consideration.
gmarkham@protonmail.com
Hello Blomper,

Thank you for using Blomp services. We are sorry to hear that you cannot install our Blomp app on your Linux OS. :/ Please note that we have 2 Blomp apps, BlompGo and BlompLive, which one are you trying to install?
How are you running Ubuntu? is it from within Windows? is it a VM? Docker?
What version of Ubuntu are you running? Ubuntu LTS? Ubuntu Core, Ubuntu Server, Ubuntu Desktop, Ubuntu Pi?
Thank you embroider5169 for asking the right questions! Kudos to you 8-) We appreciate you!

gmarkham, please answer all of our questions including embroider5169's, and provide further information and screenshots of the issue/errors, if possible. Your answers will help our tech team to detect the issue and resolve the issue ASAP.

Thank you for your cooperation.

Best Regards,
- Blomp support

Check out our video! Trust me, you're going to blomping love it. https://www.youtube.com/watch?v=klnAFs3H3bw&t=70s

gmarkham
Posts: 5
Joined: Thu Feb 04, 2021 7:03 pm

Re: ubuntu 22 client vs web

Post by gmarkham » Thu Jun 13, 2024 9:33 am

Hi,
Ok to respond to each response, I installed an app offered on the blomp site for linux here:

https://dashboard.blomp.com/dashboard/index.
It is Blomp Live, version 0.9.13 with md5 checksum:

163090e13a84a1ea9f15acc3afcc6177 BlompInstall-0.9.13

It is installed on a dell laptop running Ubuntu 22:

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.4 LTS
Release: 22.04
Codename: jammy

It starts up fine, but when I input my credentials manually or via copy/paste from text it acts as if it cannot connect or authenticate the credentials. No proxy is in use, no outbound firewall engaged, nothing but vanilla internet NAT out via current ATT hardware for fiber.

I also have BlompLive on a Mac in the same network running same version using same login. which works, so its a ubuntu specific issue I believe.

All clues offered will be greedily devoured :)

embroider5169
Posts: 57
Joined: Wed Jul 19, 2023 5:46 pm

Re: ubuntu 22 client vs web

Post by embroider5169 » Thu Jun 13, 2024 9:59 am

Thanks gmarkham,

Since you're talking about proxy and having it disabled, are you running some kind of DNS service? like pihole or adguard?

If i'm correct blomp applications are based on rclone, both use swift protocol, and you might need to add the following URL to the whitelist:
swiftproxy.acs.ai.net
(Picture below is for adguard, i dont use pihole myself)
Image

also what happens when you ping the above URL, are you able to reach it?
If you try to press login, do you get a spinning wheel? or do you receive an error? if so could you post an example of it?

gmarkham
Posts: 5
Joined: Thu Feb 04, 2021 7:03 pm

Re: ubuntu 22 client vs web

Post by gmarkham » Thu Jun 13, 2024 4:38 pm

Hi,
I just mentioned proxy to exclude it, not running any kind of ad/network screen on the host its fully open to external traffic. The host you mention resolves/pings fine:

nudell:~/Downloads$ ping swiftproxy.acs.ai.net
PING swiftproxy.acs.ai.net (205.134.187.68) 56(84) bytes of data.
64 bytes from kayabaka.ai.net (205.134.187.68): icmp_seq=1 ttl=47 time=41.1 ms

Blomplive works fine on a current intel mac on the same network, so whatever is up is specific to the linux box. My first guess was maybe it likes/doesnt like wayland?

I removed the app, reinstalled, and got some interesting warnings/ errors when it launched the app at the end:
./BlompInstall-0.9.13
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
gmarkham@nudell:~/Downloads$ ./BlompInstall-0.9.13
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
[59593] Warning: QString::arg: Argument missing: Launch Blomp, Blomp
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qt.network.ssl: QSslSocket: cannot resolve EVP_PKEY_base_id
qt.network.ssl: QSslSocket: cannot resolve SSL_get_peer_certificate
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_get_peer_certificate
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_get_peer_certificate

Perhaps theres. certificate needed for this?

These folk (who had issue with another app throwing these ssl errors) think their app of interest had issue with openssl, that the current version 3 omits functions expected by the app:

https://github.com/kiwix/kiwix-desktop/issues/871

This might be some work to fix, perhaps a updated build would be a good investment?

G

BlompSupport
Posts: 828
Joined: Wed Feb 13, 2019 4:20 pm

Re: ubuntu 22 client vs web

Post by BlompSupport » Fri Jun 14, 2024 1:19 pm

Hello gmarkham,

Thank you for sharing additional information regarding this ticket. Please allow us some time to investigate the case thoroughly. I will inform you as soon as we have a solution.

embroider5169, we are grateful for your active participation and for asking technical questions that may assist our tech team in identifying the issue. :) Your support is highly appreciated.

Wishing you both a fantastic weekend ahead!

Best Regards,
- Blomp support

Check out our video! Trust me, you're going to blomping love it. https://www.youtube.com/watch?v=klnAFs3H3bw&t=70s

embroider5169
Posts: 57
Joined: Wed Jul 19, 2023 5:46 pm

Re: ubuntu 22 client vs web

Post by embroider5169 » Fri Jun 14, 2024 2:00 pm

@Blomp you are welcome!

@gmarkham
So i've been reading into Wayland and compatibility, have you tried running it under X11 instead of wayland? X11 is still standard in linux with exclusion to ubuntu.

gmarkham
Posts: 5
Joined: Thu Feb 04, 2021 7:03 pm

Re: ubuntu 22 client vs web

Post by gmarkham » Mon Jun 17, 2024 6:29 pm

Hi,
Good thinking, I have not, when I get some time I will swap back to X and see how it works, its a simple config thing as I recall.

I am sure it will all work out in time LOL.

G

embroider5169
Posts: 57
Joined: Wed Jul 19, 2023 5:46 pm

Re: ubuntu 22 client vs web

Post by embroider5169 » Tue Jun 18, 2024 3:34 am

Hey gmarkham,

Im using debian so i cant really test it for you, sorry, but these steps should work, 3 different ways you can try it:

To switch from Wayland to X11, you can follow these steps:
Method 1: Using the Command Line


Open a terminal and type the following command: export GDK_BACKEND=x11
Press Enter to execute the command.
You can now switch to X11 by logging out and logging back in.

Method 2: Editing the Configuration File
Open the file /etc/gdm3/custom.conf in a text editor as root.
Uncomment the line WaylandEnable=false to disable Wayland.
Save the changes and restart your system.

Method 3: Using a GUI Tool
Search for and open the “Login Window” settings tool.
Click on the “Security” tab.
Uncheck the box next to “Use Wayland” and check the box next to “Use Xorg”. 4. Click “Apply” and then “OK” to save the changes.
Log out and log back in to apply the changes.

Post Reply