Rclone settings for Blomp

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Mon Feb 15, 2021 1:48 am

ajax0001 wrote:
Sun Feb 14, 2021 7:05 am
Thanks for the answer...

BlompLive for Linux works perfectly but I need using rclone.

My conf is the following:

[blomp]
type = swift
user = [myemail]
key = [mypassword]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

executing command:

rclone lsd blomp: --log-level INFO --log-file blomp.log

make me this log:

2021/02/14 12:41:12 ERROR : : error listing: container listing failed: Operation forbidden
2021/02/14 12:41:12 Failed to lsd with 2 errors: last error was: container listing failed: Operation forbidden

I tried also this conf:
-
[blomp]
type = swift
user = [myemail]
key = [mypassword]
auth = https://authenticate.blomp.com/v2.0
tenant = storage
auth_version = 2

with same error.

Rclone --version

rclone v1.53.4
- os/arch: linux/amd64
- go version: go1.15.6


Thanks
If BlompLive is working for you, that (should) mean the backend is configured properly for your account, etc, but we will check that and confirm. We will re-validate the config/settings with the latest version of rclone as well.

Strictly speaking, this error implies you aren't getting a token for authentication

A few silly questions: Are you sure rclone is using the right config file? Its not instantiated on your command line. We don't do a lot of testing with direct commands like lsd -- favoring full drive-remotes instead.

Can you try a path after the ":" on your command line?

Please let us know,

BlompTeam
BlompTeam

---
Blomp
Blomp Music Video

BlompTechie
Posts: 17
Joined: Thu Feb 25, 2021 1:01 pm

Re: Rclone settings for Blomp

Post by BlompTechie » Thu Feb 25, 2021 4:35 pm

Hi

I have tried the below command on my Ubuntu 20,.04.
It seems to work on my end without any error.

blomp.config

Code: Select all

[remote]
type = swift
user = [email]
key = [password]
auth = https://authenticate.ain.net
tenant = storage
auth_version = 2
mount.sh

Code: Select all

rclone --config blomp.config mount remote:"[email]" Blomp --daemon --vfs-cache-mode full --vfs-read-chunk-size-limit 0 --vfs-cache-max-age 10m --dir-cache-time=5m --no-modtime --allow-non-empty --transfers 32 --file-perms 0666 --dir-perms 0777
Also, below is my rclone version

rclone v1.50.2
- os/arch: linux/amd64
- go version: go1.13.6

Please let me know.

Thank you

BlompTechie

orip99
Posts: 5
Joined: Fri Jul 23, 2021 7:46 am

Re: Rclone settings for Blomp

Post by orip99 » Sat Jul 31, 2021 7:25 pm

Hello:
When I run the following command on Windows 10 (build 2009) via CMD and PowerShell:

2021/07/31 18:24:12 Failed to about: About call failed: container listing failed: Operation forbidden

I haver tried using auth points https://authenticate.ain.net & https://authenticate.blomp.com

Is this a Blomp related issue?

orip99
Posts: 5
Joined: Fri Jul 23, 2021 7:46 am

Re: Rclone settings for Blomp

Post by orip99 » Sat Jul 31, 2021 7:28 pm

The command was:

./rclone.exe about Blomp:

orip99
Posts: 5
Joined: Fri Jul 23, 2021 7:46 am

Re: Rclone settings for Blomp

Post by orip99 » Sat Jul 31, 2021 9:34 pm

Hello Blompsters:
It works great now. I was being too impatient and after logging into the desktop app after issuing the sync command, everything shows up as advertised.

THANKS!!!

Post Reply