Rclone settings for Blomp

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Tue Dec 01, 2020 5:17 pm

BlompTeam wrote:
Tue Dec 01, 2020 5:14 pm
BlompTeam wrote:
Tue Dec 01, 2020 5:06 pm
johnnymnemonic wrote:
Tue Dec 01, 2020 12:40 am
Hey guys. I appreciate the effort in trying to help with correct settings. For the life of me I still cannot get the remote to MOUNT and startup Blomp using an SH script. Here's what I have. I am connecting multiple remotes using a SINGLE config script. gDrive, Box, OneDrive and so on and all of them connect without issue whatsoever ... except Blomp. I've been trying for WEEKS ... and I am MSDN certified and have gotten very frustrated. I must be overlooking something S&S ... Simple and Stupid (on my behalf). My config uses:

[Blomp]
type = swift
user = [user@email]
key = [password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

The settings above exist in my rclone.config file along with [gDrive], [OneDrive], [Box], [Mega], and so on. I want to use a SINGLE config file to load all the remotes at boot up. Here is how I achieve this:

remote.sh (file placed in my user startup folder, allowed to be executable at boot time, run at startup to auto-mount):

-
#!/bin/sh
sleep 20
rclone mount --vfs-cache-mode full -v --allow-non-empty "gDrive": ~/Cloud/gDrive --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Box": ~/Cloud/Box --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "OneDrive": ~/Cloud/OneDrive --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Mega": ~/Cloud/Mega --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Mail": ~/Cloud/Mail --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "DropBox": ~/Cloud/DropBox --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "pCloud": ~/Cloud/pCloud --daemon && rclone --config ~/blomp.config mount remote:{email} ~/Cloud/Blomp --vfs-cache-mode full -v --allow-non-empty --transfers 32 --daemon
-

In this configuration I can load ALL my remotes and auto-mount them at boot up / login ... all except for Blomp. This script above uses a SINGLE rclone.config file and uses the "gDrive" quote command above at login to call the [gDrive] settings created using 'rclone config' in Terminal at rclone remote creation and provides any associated credentials as well for each service and stored in the single rclone.config in my ~/.config dir.

Can ANYONE please fill in the incorrect command or missing command or whatever needs to be plugged into that remote.sh script file above to allow Blomp to auto-load / mount at start-up like all my other remotes do perfectly? I would very much appreciate it. I have tried every variation and combination possible to no avail. I very much want to use a SINGLE rclone.config for loading all the remotes and not have to load that extra 'blomp.config' file. Thank You so much for the helping hand. Best regards.
Hi, so there are a few things that jump out...

In this file:

[Blomp]
type = swift
user = [user@email]
key = [password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

You are calling us Blomp, but in your command line you are calling us "remote"... they should match. Either call us Blomp:{email] on your command line or remote in your config file.

I'd suggest adding this to your command line too:

--log-level INFO --log-file /tmp/rclone.blomp.log

so you can see what error rclone is "seeing".

This may or may not be required, but you can try:

auth = https://authenticate.blomp.com/v2.0

Please let us know!

thanks,

BlompTeam
Verified to work:

[remote]
type = swift
user = [email address]
key = [password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

mount_blomp.sh
#!/bin/sh

mkdir -p /mnt/blomp
/usr/bin/rclone --config=/tmp/blomp.conf mount remote:[email] /mnt/blomp --no-modtime --log-level INFO --log-file /tmp/rclone.blomp.log --allow-non-empty

Please let us know!

Best,

BlompTeam
We used the latest version of rclone in our test. The latest version does not support vfs-cache... but we have used the older version in the past with those options. My guess is that when you fix the remote word you'll be in great shape!

Best,

BlompTeam
BlompTeam

---
Blomp
Blomp Music Video

johnnymnemonic
Posts: 5
Joined: Wed Oct 28, 2020 6:58 pm

Re: Rclone settings for Blomp

Post by johnnymnemonic » Sun Dec 06, 2020 11:35 am

Hey Blomp! Thank you for the speedy replies and support. Here's what I got now after entering EXACTLY what you suggested into the conf file. It does connect but now throws something totally new at me. Laughs --->

2020/12/06 11:15:31 INFO : Swift container [email]: poll-interval is not supported by this remote
2020/12/06 11:15:48 ERROR : Swift container [email]: Statfs failed: container listing failed: Operation forbidden
2020/12/06 11:23:07 INFO : Signal received: terminated
2020/12/06 11:23:07 INFO : Exiting...

Any advice? Thanks so much!

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Mon Dec 07, 2020 2:17 pm

johnnymnemonic wrote:
Sun Dec 06, 2020 11:35 am
Hey Blomp! Thank you for the speedy replies and support. Here's what I got now after entering EXACTLY what you suggested into the conf file. It does connect but now throws something totally new at me. Laughs --->

2020/12/06 11:15:31 INFO : Swift container [email]: poll-interval is not supported by this remote
2020/12/06 11:15:48 ERROR : Swift container [email]: Statfs failed: container listing failed: Operation forbidden
2020/12/06 11:23:07 INFO : Signal received: terminated
2020/12/06 11:23:07 INFO : Exiting...

Any advice? Thanks so much!
From Rclone's support forum:

https://forum.rclone.org/t/rclone-mount-error/18305

Seems like a typo on your end. Colon missing somewhere.

Respectfully,

BlompTeam
BlompTeam

---
Blomp
Blomp Music Video

johnnymnemonic
Posts: 5
Joined: Wed Oct 28, 2020 6:58 pm

Re: Rclone settings for Blomp

Post by johnnymnemonic » Tue Dec 08, 2020 1:47 am

Hello! Hmmm. I am at a loss. Here is my entire command EXACTLY --->

#!/bin/sh
sleep 60
mkdir -p ~/Cloud/Blomp && rclone mount "Blomp":[my-email] ~/Cloud/Blomp --no-modtime --log-level INFO --log-file ~/rclone.blomp.log --allow-non-empty --transfers 32 --daemon

And here is what is contained in the rclone.conf file EXACTLY --->

[Blomp]
type = swift
user = [my-email]
key = [my-password]
auth = https://authenticate.blomp.com/v2.0
tenant = storage
auth_version = 2

I have no idea what's happening. I do appreciate all your efforts with support. Maybe there is another user who has an idea I can try to make this work? I welcome any suggestions. I have exhausted all my efforts trying to get it working. Thanks again everyone for your assistance. Regards, Johnny

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Thu Dec 10, 2020 1:15 am

johnnymnemonic wrote:
Tue Dec 08, 2020 1:47 am
Hello! Hmmm. I am at a loss. Here is my entire command EXACTLY --->

#!/bin/sh
sleep 60
mkdir -p ~/Cloud/Blomp && rclone mount "Blomp":[my-email] ~/Cloud/Blomp --no-modtime --log-level INFO --log-file ~/rclone.blomp.log --allow-non-empty --transfers 32 --daemon

And here is what is contained in the rclone.conf file EXACTLY --->

[Blomp]
type = swift
user = [my-email]
key = [my-password]
auth = https://authenticate.blomp.com/v2.0
tenant = storage
auth_version = 2

I have no idea what's happening. I do appreciate all your efforts with support. Maybe there is another user who has an idea I can try to make this work? I welcome any suggestions. I have exhausted all my efforts trying to get it working. Thanks again everyone for your assistance. Regards, Johnny
Try removing the quotes around the word "Blomp"...

What is your logfile saying? either /var/log/syslog or ~rclone.blomp.log

thanks!

BlompTeam
BlompTeam

---
Blomp
Blomp Music Video

johnnymnemonic
Posts: 5
Joined: Wed Oct 28, 2020 6:58 pm

Re: Rclone settings for Blomp

Post by johnnymnemonic » Thu Dec 17, 2020 10:07 pm

Hello! Removing the quotes around "Blomp" doesn't change the error I get in the log which follows:

2020/12/17 21:43:32 INFO : Signal received: terminated
2020/12/17 21:43:32 INFO : Exiting...
2020/12/17 21:46:36 INFO : Swift root: poll-interval is not supported by this remote

The error above repeats at every attempt to connect and is the ONLY error listed in the log file.

The remote seems to be connecting and also mounting on my end because I can see the mount and icon appear after the script runs. It just fails to "list" the files on the Blomp remote side into my local file browser yet it shows the successfully mounted directory. I have no clue. I've tried everything and am about to wash my hands of it. Being unable to use this remote is unfortunate since I like your service. I do appreciate all the support efforts. Enjoy the holiday everyone! Regards, Johnny

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Fri Dec 18, 2020 3:13 pm

johnnymnemonic wrote:
Thu Dec 17, 2020 10:07 pm
Hello! Removing the quotes around "Blomp" doesn't change the error I get in the log which follows:

2020/12/17 21:43:32 INFO : Signal received: terminated
2020/12/17 21:43:32 INFO : Exiting...
2020/12/17 21:46:36 INFO : Swift root: poll-interval is not supported by this remote

The error above repeats at every attempt to connect and is the ONLY error listed in the log file.

The remote seems to be connecting and also mounting on my end because I can see the mount and icon appear after the script runs. It just fails to "list" the files on the Blomp remote side into my local file browser yet it shows the successfully mounted directory. I have no clue. I've tried everything and am about to wash my hands of it. Being unable to use this remote is unfortunate since I like your service. I do appreciate all the support efforts. Enjoy the holiday everyone! Regards, Johnny
I don't know what to tell you.

When I retry our config that we provided you above, it works. When I try your config, I get fuser errors.

Code: Select all


mount_blomp.sh
#!/bin/sh

mkdir -p /mnt/blomp
/usr/bin/rclone --config=/tmp/blomp.conf mount remote:blomp@xxxx.com /mnt/blomp --no-modtime --log-level INFO --log-file /tmp/rclone.blomp.log --allow-non-empty

blomp.conf
[remote]
type = swift
user = blomp@xxxx.com
key = yyyyyy
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2


Two things noticed when we tried your config. One, yours doesn't specify the config file on the command line. Rclone will use its default path... which may not be where you've stored this config. You are definitely running an old version of rclone, so our parameters (e.g. not needing --daemon) may mistreat yours. So we'd recommend upgrading rclone to the latest and updating your mounts.. or at least using the latest to mount Blomp.

You don't have the log-level turned up. You have a "v2.0" at the end of your auth line that may be deprecated.

Our conclusion, based on testing and retesting, is that the changes you are making to our reference configuration above are breaking it. Hopefully you'll try our config with the latest version of rclone.

Best,

BlompTeam
BlompTeam

---
Blomp
Blomp Music Video

ajax0001
Posts: 2
Joined: Sat Feb 13, 2021 10:56 am

Re: Rclone settings for Blomp

Post by ajax0001 » Sat Feb 13, 2021 12:54 pm

I have the same problem of johnnymnemonic:

rclone lsd blomp1: --log-level INFO
2021/02/13 18:53:05 ERROR : : error listing: container listing failed: Operation forbidden
2021/02/13 18:53:05 Failed to lsd with 2 errors: last error was: container listing failed: Operation forbidden

So now it's impossible to use rclone?

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Sat Feb 13, 2021 6:29 pm

ajax0001 wrote:
Sat Feb 13, 2021 12:54 pm
I have the same problem of johnnymnemonic:

rclone lsd blomp1: --log-level INFO
2021/02/13 18:53:05 ERROR : : error listing: container listing failed: Operation forbidden
2021/02/13 18:53:05 Failed to lsd with 2 errors: last error was: container listing failed: Operation forbidden

So now it's impossible to use rclone?
That shouldn't be the conclusion you reach from this.

BlompGo uses Rclone and works every day.

Those having problems with Rclone are using it directly with variations to the configs we've provided. They may work or may not, but while we are happy to help, we can't guarantee any particular config other than what we provide in BlompGo.

So posting your error message without the config or debug log makes it difficult to help.

Best!

BlompTeam
BlompTeam

---
Blomp
Blomp Music Video

ajax0001
Posts: 2
Joined: Sat Feb 13, 2021 10:56 am

Re: Rclone settings for Blomp

Post by ajax0001 » Sun Feb 14, 2021 7:05 am

Thanks for the answer...

BlompLive for Linux works perfectly but I need using rclone.

My conf is the following:

[blomp]
type = swift
user = [myemail]
key = [mypassword]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

executing command:

rclone lsd blomp: --log-level INFO --log-file blomp.log

make me this log:

2021/02/14 12:41:12 ERROR : : error listing: container listing failed: Operation forbidden
2021/02/14 12:41:12 Failed to lsd with 2 errors: last error was: container listing failed: Operation forbidden

I tried also this conf:
-
[blomp]
type = swift
user = [myemail]
key = [mypassword]
auth = https://authenticate.blomp.com/v2.0
tenant = storage
auth_version = 2

with same error.

Rclone --version

rclone v1.53.4
- os/arch: linux/amd64
- go version: go1.15.6


Thanks

Post Reply