Rclone settings for Blomp

upload
Posts: 2
Joined: Tue Apr 30, 2019 4:27 am

Rclone settings for Blomp

Post by upload » Wed May 01, 2019 4:22 am

Can somebody write here quick step-by-step guide to create new rclone remote to blomp.com? Fastest way - paste output of command

Code: Select all

rclone config show blomp
where "blomp" is name of remote in your rclone.conf(without colon). Replace credentials with xxxxx, of course. Thanks!

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Mon May 06, 2019 3:12 am

Hi upload,

To connect to your storage with rclone you have to create the config file first. You can create the config file with rclone command: rclone config. This command enables you to have the config in plain text or you can encrypt it with a password for more security. The variables for rclone config file are following:

type = swift
user = [your email]
key = [your password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

Other variables can be ignored, the above are the only ones you need to connect to Blomp storage.

Your config now looks like:

Code: Select all

[remote]
type = swift
user = [your email]
key = [your password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2
You can now use rclone to connect to your storage. For example, list the content of your storage:

Code: Select all

rclone.exe --config=my.conf ls remote:[your email]
Or sync your container with a local directory (warning, this will delete any excess files in your bucket):

Code: Select all

rclone.exe --config=my.conf sync /LOCAL/FOLDER/ remote:[your email]
BlompTeam

---
Blomp
Blomp Music Video

upload
Posts: 2
Joined: Tue Apr 30, 2019 4:27 am

Re: Rclone settings for Blomp

Post by upload » Tue May 07, 2019 10:12 am

Thank you very much.
I know how to use rclone. But immediately after registration in my "dashboard -> advanced" auth url was "authenticate.ain.net" and rclone has error. Now with "authenticate.blomp.com" rclone can connect to blomp storage. Thanks again.

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Wed May 08, 2019 11:07 pm

thanks, both URLs should work. :D

Happy Blomping!
BlompTeam

---
Blomp
Blomp Music Video

johnnymnemonic
Posts: 5
Joined: Wed Oct 28, 2020 6:58 pm

Re: Rclone settings for Blomp

Post by johnnymnemonic » Wed Oct 28, 2020 8:26 pm

Hey all! I setup the config exactly as described. It fails to AUTH and connect. Any suggestions? Which one of the profiles inside Rclone will work with Blomp so that a person can use the "rclone config" setup routine to create the file and get the authorization token so the password isn't sent in plain sight.

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Fri Oct 30, 2020 11:39 pm

johnnymnemonic wrote:
Wed Oct 28, 2020 8:26 pm
Hey all! I setup the config exactly as described. It fails to AUTH and connect. Any suggestions? Which one of the profiles inside Rclone will work with Blomp so that a person can use the "rclone config" setup routine to create the file and get the authorization token so the password isn't sent in plain sight.
Can you try this again? BlompGo and direct Rclone are working correctly. The password you send for login is encrypted over the TLS v1.2 connection.

So the command we use in BlompGo for rclone is this:

rclone.exe --config blomp.config mount remote:[user@email] Z: --vfs-cache-mode full --allow-other --transfers 32

blomp.config says:

[remote]
type = swift
user = [user@email]
key = [password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2


[it may say auth_verison=3 in a future version].

that works for many users.

Let us know how we can help,

BlompTeam
BlompTeam

---
Blomp
Blomp Music Video

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Sat Oct 31, 2020 11:51 pm

Moving this to Technical...
BlompTeam

---
Blomp
Blomp Music Video

johnnymnemonic
Posts: 5
Joined: Wed Oct 28, 2020 6:58 pm

Re: Rclone settings for Blomp

Post by johnnymnemonic » Tue Dec 01, 2020 12:40 am

Hey guys. I appreciate the effort in trying to help with correct settings. For the life of me I still cannot get the remote to MOUNT and startup Blomp using an SH script. Here's what I have. I am connecting multiple remotes using a SINGLE config script. gDrive, Box, OneDrive and so on and all of them connect without issue whatsoever ... except Blomp. I've been trying for WEEKS ... and I am MSDN certified and have gotten very frustrated. I must be overlooking something S&S ... Simple and Stupid (on my behalf). My config uses:

[Blomp]
type = swift
user = [user@email]
key = [password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

The settings above exist in my rclone.config file along with [gDrive], [OneDrive], [Box], [Mega], and so on. I want to use a SINGLE config file to load all the remotes at boot up. Here is how I achieve this:

remote.sh (file placed in my user startup folder, allowed to be executable at boot time, run at startup to auto-mount):

-
#!/bin/sh
sleep 20
rclone mount --vfs-cache-mode full -v --allow-non-empty "gDrive": ~/Cloud/gDrive --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Box": ~/Cloud/Box --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "OneDrive": ~/Cloud/OneDrive --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Mega": ~/Cloud/Mega --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Mail": ~/Cloud/Mail --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "DropBox": ~/Cloud/DropBox --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "pCloud": ~/Cloud/pCloud --daemon && rclone --config ~/blomp.config mount remote:{email} ~/Cloud/Blomp --vfs-cache-mode full -v --allow-non-empty --transfers 32 --daemon
-

In this configuration I can load ALL my remotes and auto-mount them at boot up / login ... all except for Blomp. This script above uses a SINGLE rclone.config file and uses the "gDrive" quote command above at login to call the [gDrive] settings created using 'rclone config' in Terminal at rclone remote creation and provides any associated credentials as well for each service and stored in the single rclone.config in my ~/.config dir.

Can ANYONE please fill in the incorrect command or missing command or whatever needs to be plugged into that remote.sh script file above to allow Blomp to auto-load / mount at start-up like all my other remotes do perfectly? I would very much appreciate it. I have tried every variation and combination possible to no avail. I very much want to use a SINGLE rclone.config for loading all the remotes and not have to load that extra 'blomp.config' file. Thank You so much for the helping hand. Best regards.

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Tue Dec 01, 2020 5:06 pm

johnnymnemonic wrote:
Tue Dec 01, 2020 12:40 am
Hey guys. I appreciate the effort in trying to help with correct settings. For the life of me I still cannot get the remote to MOUNT and startup Blomp using an SH script. Here's what I have. I am connecting multiple remotes using a SINGLE config script. gDrive, Box, OneDrive and so on and all of them connect without issue whatsoever ... except Blomp. I've been trying for WEEKS ... and I am MSDN certified and have gotten very frustrated. I must be overlooking something S&S ... Simple and Stupid (on my behalf). My config uses:

[Blomp]
type = swift
user = [user@email]
key = [password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

The settings above exist in my rclone.config file along with [gDrive], [OneDrive], [Box], [Mega], and so on. I want to use a SINGLE config file to load all the remotes at boot up. Here is how I achieve this:

remote.sh (file placed in my user startup folder, allowed to be executable at boot time, run at startup to auto-mount):

-
#!/bin/sh
sleep 20
rclone mount --vfs-cache-mode full -v --allow-non-empty "gDrive": ~/Cloud/gDrive --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Box": ~/Cloud/Box --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "OneDrive": ~/Cloud/OneDrive --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Mega": ~/Cloud/Mega --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Mail": ~/Cloud/Mail --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "DropBox": ~/Cloud/DropBox --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "pCloud": ~/Cloud/pCloud --daemon && rclone --config ~/blomp.config mount remote:{email} ~/Cloud/Blomp --vfs-cache-mode full -v --allow-non-empty --transfers 32 --daemon
-

In this configuration I can load ALL my remotes and auto-mount them at boot up / login ... all except for Blomp. This script above uses a SINGLE rclone.config file and uses the "gDrive" quote command above at login to call the [gDrive] settings created using 'rclone config' in Terminal at rclone remote creation and provides any associated credentials as well for each service and stored in the single rclone.config in my ~/.config dir.

Can ANYONE please fill in the incorrect command or missing command or whatever needs to be plugged into that remote.sh script file above to allow Blomp to auto-load / mount at start-up like all my other remotes do perfectly? I would very much appreciate it. I have tried every variation and combination possible to no avail. I very much want to use a SINGLE rclone.config for loading all the remotes and not have to load that extra 'blomp.config' file. Thank You so much for the helping hand. Best regards.
Hi, so there are a few things that jump out...

In this file:

[Blomp]
type = swift
user = [user@email]
key = [password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

You are calling us Blomp, but in your command line you are calling us "remote"... they should match. Either call us Blomp:{email] on your command line or remote in your config file.

I'd suggest adding this to your command line too:

--log-level INFO --log-file /tmp/rclone.blomp.log

so you can see what error rclone is "seeing".

This may or may not be required, but you can try:

auth = https://authenticate.blomp.com/v2.0

Please let us know!

thanks,

BlompTeam
BlompTeam

---
Blomp
Blomp Music Video

User avatar
BlompTeam
Site Admin
Posts: 405
Joined: Wed Nov 07, 2018 8:14 am

Re: Rclone settings for Blomp

Post by BlompTeam » Tue Dec 01, 2020 5:14 pm

BlompTeam wrote:
Tue Dec 01, 2020 5:06 pm
johnnymnemonic wrote:
Tue Dec 01, 2020 12:40 am
Hey guys. I appreciate the effort in trying to help with correct settings. For the life of me I still cannot get the remote to MOUNT and startup Blomp using an SH script. Here's what I have. I am connecting multiple remotes using a SINGLE config script. gDrive, Box, OneDrive and so on and all of them connect without issue whatsoever ... except Blomp. I've been trying for WEEKS ... and I am MSDN certified and have gotten very frustrated. I must be overlooking something S&S ... Simple and Stupid (on my behalf). My config uses:

[Blomp]
type = swift
user = [user@email]
key = [password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

The settings above exist in my rclone.config file along with [gDrive], [OneDrive], [Box], [Mega], and so on. I want to use a SINGLE config file to load all the remotes at boot up. Here is how I achieve this:

remote.sh (file placed in my user startup folder, allowed to be executable at boot time, run at startup to auto-mount):

-
#!/bin/sh
sleep 20
rclone mount --vfs-cache-mode full -v --allow-non-empty "gDrive": ~/Cloud/gDrive --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Box": ~/Cloud/Box --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "OneDrive": ~/Cloud/OneDrive --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Mega": ~/Cloud/Mega --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "Mail": ~/Cloud/Mail --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "DropBox": ~/Cloud/DropBox --daemon && rclone mount --vfs-cache-mode full -v --allow-non-empty "pCloud": ~/Cloud/pCloud --daemon && rclone --config ~/blomp.config mount remote:{email} ~/Cloud/Blomp --vfs-cache-mode full -v --allow-non-empty --transfers 32 --daemon
-

In this configuration I can load ALL my remotes and auto-mount them at boot up / login ... all except for Blomp. This script above uses a SINGLE rclone.config file and uses the "gDrive" quote command above at login to call the [gDrive] settings created using 'rclone config' in Terminal at rclone remote creation and provides any associated credentials as well for each service and stored in the single rclone.config in my ~/.config dir.

Can ANYONE please fill in the incorrect command or missing command or whatever needs to be plugged into that remote.sh script file above to allow Blomp to auto-load / mount at start-up like all my other remotes do perfectly? I would very much appreciate it. I have tried every variation and combination possible to no avail. I very much want to use a SINGLE rclone.config for loading all the remotes and not have to load that extra 'blomp.config' file. Thank You so much for the helping hand. Best regards.
Hi, so there are a few things that jump out...

In this file:

[Blomp]
type = swift
user = [user@email]
key = [password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

You are calling us Blomp, but in your command line you are calling us "remote"... they should match. Either call us Blomp:{email] on your command line or remote in your config file.

I'd suggest adding this to your command line too:

--log-level INFO --log-file /tmp/rclone.blomp.log

so you can see what error rclone is "seeing".

This may or may not be required, but you can try:

auth = https://authenticate.blomp.com/v2.0

Please let us know!

thanks,

BlompTeam
Verified to work:

[remote]
type = swift
user = [email address]
key = [password]
auth = https://authenticate.blomp.com
tenant = storage
auth_version = 2

mount_blomp.sh
#!/bin/sh

mkdir -p /mnt/blomp
/usr/bin/rclone --config=/tmp/blomp.conf mount remote:[email] /mnt/blomp --no-modtime --log-level INFO --log-file /tmp/rclone.blomp.log --allow-non-empty

Please let us know!

Best,

BlompTeam
BlompTeam

---
Blomp
Blomp Music Video

Post Reply